解惑

解己之惑,解人之惑

标签:版本

版本陷阱

前段时间接手了系统的升级功能,看了安装和升级的部分,关于版本的处理简直不能直视,因为全部是hard code的,每次版本有任何修改都需要修改脚本,我接手后重写了升级部分,但是没有想到最后还是栽在了版本问题上,因为我调用了一个系统原有的升级脚本,而那个脚本需要传入包的版本号,所以第一个升级包中我也hard code了那个包的版本号,谁想GA的前一天友队升级了那个包,我们的Build工程师更新了那个包,改了相关的脚本但是没有更新升级部分,更大的集成的时候就出问题了。。。真的是怕什么来什么。

回到MSN7的时代

公司的防火墙对MSN有限限制,7和7.5版本的没有问题,7.5以上版本就不行了,最新的9.0用的时候会不停的自动断线和上线,根本没有办法用,前端是时间一直在用meebo,但是发现meebo在处理离线消息和好友请求方面有问题,这次忍无可忍,安装7.0版本的MSN了。
如果装7.5的MSN则会提示升级,否则不能用,为什么7.0的就可以呢。

千万不要升级到最新版本的msn

今天手痒,看到msn提示有新版本就升级了一把,结果每隔几秒就自动断线了,汗一个,想卸载,找了半天没有找到,后来试了下,发现藏在windows live essential里面了。卸载,重新安装新版本,一切恢复正常。

痛苦的Pluto使用经历

项目中要使用到Pluto,今天研究了一下,但是经历着实痛苦。
我们的tomcat使用的是古老的jboss带的版本,我就用我自己安装的tomcat5.0.28做了下试验,结果不成功,后来下载了一个bundle版本,其实就是已经包含了tomcat的版本,但是它带的版本是5.5.20,我就对照了下,把我能看出来的不同都对应的在tomcat5.0.28下做了修改,应用是可以跑起来了,但是登录进首页的时候出了一个NullPointerException,原因不明也没有那么多时间去研究,后来就下载了老版本的1.0.1试验,结果应用都不能起来。没有办法,只能从原代码编译试试,又去下载maven,结果使用JDK1.4无法编译,它的代码中使用了一个JDK1.5才有的方法,手工修改源代码,编译通过了,但是在安装的时候又出了问题,报告pluto的一个plugin不存在。然后又下载pluto的1.0.1版本的原代码,又下载maven1.0.2版本编译,依然不成功,原因是不能解析project.xml文件,彻底无语了。

更新:
回家后又弄了一下,终于在tomcat5.0.28下成功手工发布了pluto1.1,问题是我依然要使用JDK1.5才能看到结果运行正常,使用JDK1.4时会出现编译pluto1.1时遇到的那个问题的运行期版本。步骤为将bundle版本下的文件拷贝到tomcat5.0.28的对应目录:

  • conf\Catalina\localhost\pluto.xml
  • \shared\lib
  • \PlutoDomain\pluto-portal-1.1.0.war
  • 编辑tomcat-users.xml文件,增加pluto用户

要解决JDK版本问题,可能的办法就是修改源代码(pluto-1.1.0-src\pluto-container\src\main\java\org\apache\pluto\core\ContainerInvocation.java,把64行注释掉就行)后在JDK1.4下编译,然后把那个有问题的类替换掉,当然可能会有其他的问题。

© 2022 解惑

本主题由Anders Noren提供向上 ↑